Get Paid to Participate - up to $1 per post!     Twitter     Facebook     Google+
Hosting Discussion
 

forgot password?



Reply


Old
  Post #1 (permalink)   02-24-2016, 06:19 PM
HD Management Staff
 
Artashes's Avatar
 
Join Date: Apr 2003
Posts: 9,764

Status: Artashes is offline
Question for those who might have the answer. What might be the reason for email forwarder not to work? I set it up through cPanel.

The original email account works. The email forwarder directed to the original account won't.

It isn't a life critical issue and I can totally do without it, but I am curious.
 
 
 


Old
  Post #2 (permalink)   02-25-2016, 05:20 AM
HD Wizard
 
easyhostmedia's Avatar
 
Join Date: Mar 2011
Location: Northumberland, UK
Posts: 4,986
Send a message via MSN to easyhostmedia

Status: easyhostmedia is offline
Quote:
Originally Posted by Artashes View Post
Question for those who might have the answer. What might be the reason for email forwarder not to work? I set it up through cPanel.

The original email account works. The email forwarder directed to the original account won't.

It isn't a life critical issue and I can totally do without it, but I am curious.
so its not just me then, i have had a couple clients mention this.

I think its a cpanel issue as i also found out that creating an FTP user in cpanel also does not work
__________________
Terry Robertson - CEO The Easyhost Media Group
Niceday Hosting - Affordable Hosting
PowerSSL - - We Secure your World
The Scamlist Forum - Fighting against scammers
 
 
 


Old
  Post #3 (permalink)   02-25-2016, 01:53 PM
HD Guru
 
Join Date: Jan 2013
Posts: 756
Send a message via AIM to cheapdedicated Send a message via Yahoo to cheapdedicated Send a message via Skype™ to cheapdedicated

Status: cheapdedicated is offline
I just tried it on one of the domains on our servers and whooooo It doesnt work. I guess its a cPanel bug.
__________________
Techsys Ltd | Dedicated Servers | V.P.S | Free Plesk Panel
G8 Servers cPanel Reseller VPS Reseller Dedicated Server Resellers

G8 Host Cheap Domains | Shared Hosting | SSL
 
 
 


Old
  Post #4 (permalink)   02-25-2016, 03:10 PM
HD Amateur
 
Join Date: Feb 2016
Posts: 58

Status: ExonHost is offline
I don't think it's cPanel bug. Forwarding is working just fine for me.

Quote:
Originally Posted by cheapdedicated View Post
I just tried it on one of the domains on our servers and whooooo It doesnt work. I guess its a cPanel bug.
__________________
ExonHost- Blazing Fast Pure SSD Hosting
Pure SSD, LiteSpeed, PHP 7, Optimized MySQL| DDOS Protected Hosting
24/7X365 Technical Support | 99.9% Uptime Guarantee | 30 days Moneyback Guarantee!
 
 
 


Old
  Post #5 (permalink)   02-25-2016, 03:57 PM
HD Management Staff
 
Artashes's Avatar
 
Join Date: Apr 2003
Posts: 9,764

Status: Artashes is offline
I am relieved it isn't just me. I will try again tonight..

In the meantime, if anyone hears anything from cPanel, please update us here as well.
 
 
 


Old
  Post #6 (permalink)   02-25-2016, 10:50 PM
Account Disabled
 
Join Date: May 2012
Posts: 969

Status: Collabora is offline
Its not a cpanel bug. There are some gotchas when setting up email forwarding.

Other than that, have host check spamd for issues.

Now for the gotchas, tell us more about your config. Are both mailboxes on the same domain? If they are on different domains are both domains on the same server? Is one of them remote?

What kind of tests have you done? For example, if artashes@domain.com forwards to artashes2@gmail.com and you try to send mail from the gmail account to artashes mailbox you probably won't receive it at artashes2
 
 
 
The Following User Says Thank You to Collabora For This Useful Post:
Artashes (02-26-2016)


Old
  Post #7 (permalink)   02-26-2016, 10:05 AM
HD Management Staff
 
Artashes's Avatar
 
Join Date: Apr 2003
Posts: 9,764

Status: Artashes is offline
Same domain, same server.

forwarder@domain.com forwards to email@domain.com

I am testing sending the email to both forwarder@ and email@, only the messages to email@ go through.
 
 
 


Old
  Post #8 (permalink)   02-26-2016, 11:07 AM
Account Disabled
 
Join Date: May 2012
Posts: 969

Status: Collabora is offline
Quote:
Originally Posted by Artashes View Post
Same domain, same server.

forwarder@domain.com forwards to email@domain.com

I am testing sending the email to both forwarder@ and email@, only the messages to email@ go through.
So if I understand you correctly, you cannot receive mail at email@ even when you send directly?

Assuming I am not understanding correctly, try disabling spamassassin in cpanel and test again. If forwarding is still not working, and you have access to server, check your exim logs and spamd configuration (or have host do it)
 
 
 


Old
  Post #9 (permalink)   02-26-2016, 11:53 AM
HD Management Staff
 
Artashes's Avatar
 
Join Date: Apr 2003
Posts: 9,764

Status: Artashes is offline
Keeping in mind that anything sent to forwarder@domain.com has to be forwarded to email@domain.com:

From a third party email account, I tested by sending two test messages to forwarder@domain.com, neither of which were received by email@domain.com

From the same third party email account, I sent a test message directly to email@domain.com, to see whether the problem is also with that account, but that wasn't the case - the message was received without issue.

Direct emails are sent fine, emails through forwarder for some reason are not.

Just logged into the server: "Apache SpamAssassin™ is currently disabled."

I will ask the host to check the exim logs and spamd configuration.
 
 
 


Old
  Post #10 (permalink)   02-26-2016, 07:36 PM
HD Management Staff
 
Artashes's Avatar
 
Join Date: Apr 2003
Posts: 9,764

Status: Artashes is offline
Here is an interesting twist. The server logs show that all mail to forwarder is going through. And so far 2 different Gmail accounts have successfully sent a message to forwarder@domain.com

However, the forwarder@ still does not receive emails from my personal Gmail account. The server does indeed show the message goes through, but I don't receive it.

This is the first time I am this confused by an email forwarding issue.
 
 
 


Old
  Post #11 (permalink)   06-03-2016, 05:40 AM
HD Newbie
 
Join Date: Apr 2016
Location: Kazakhstan
Posts: 14

Status: imort is offline
Quote:
Originally Posted by Artashes View Post
However, the forwarder@ still does not receive emails from my personal Gmail account. The server does indeed show the message goes through, but I don't receive it.

This is the first time I am this confused by an email forwarding issue.
Can you configure email forwarding to some other mailbox on the mail server you have control on, and check the logs on them?

I think you should see received messages if they're send through and you'll have a chance to look at the headers, etc.
 
 
 


Old
  Post #12 (permalink)   06-05-2016, 04:37 AM
HD Guru
 
Join Date: Jan 2013
Posts: 756
Send a message via AIM to cheapdedicated Send a message via Yahoo to cheapdedicated Send a message via Skype™ to cheapdedicated

Status: cheapdedicated is offline
I had this same error (I just set up a forwarder after I read here for testing nothing serious.) After failing for a while I deleted the forwarder and recreated it pointing the forwarder to the same email as before and Boom it worked. Why it had not worked is beyond me and the server will kill you if you say it did not deliver the email coz its log says it did!
__________________
Techsys Ltd | Dedicated Servers | V.P.S | Free Plesk Panel
G8 Servers cPanel Reseller VPS Reseller Dedicated Server Resellers

G8 Host Cheap Domains | Shared Hosting | SSL
 
 
 
Reply

Thread Tools

New Post New Post   Old Post Old Post
Posting Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Sponsored By: