Hosting Discussion

Hosting Discussion (http://www.hostingdiscussion.com/)
-   Website Development & Design (http://www.hostingdiscussion.com/website-development-design/)
-   -   WHMCS Bridge...so slow? (http://www.hostingdiscussion.com/website-development-design/41623-whmcs-bridge-so-slow.html)


25Fast 04-11-2016 01:33 AM

WHMCS Bridge...so slow?
 
Good morning,
we changed our system to WP + WHMCS Bridge..but now the website is so slow, you know why? There is something to configure to have it faster? Before WHMCS bridge, with other system (like only WP for example) the website was fast. Any information?
Best Regards

NetM 04-16-2016 11:56 AM

Do you have big images or scripts? Also use WP Super Cache plugin for Wordpress. You will see the difference instant.

cheapdedicated 04-19-2016 04:38 AM

If all fails you can instead use WHMCS integration instead of a third party plugins.

whmcsguru 05-06-2016 05:42 PM

caching WP helps, but in the end, WP bridge is, indeed, incredibly slow. I've seen this run from 15s all the way to to 3 minutes myself.

It's likely that the cause of this is the fact that they're not utilizing the local keys properly. I've seen more than one instance where the key should have been stored in the DB, but their servers were down, causing the server to think the key was invalid, thusly throwing me into the default 'five' theme. Frustrating to say the least.

whmcsguru 05-06-2016 09:49 PM

I just thought I'd update this here with what I have found myself. This is still taking a ton of time, but I've managed to cut this down slightly (ie: no longer going more than 30s).

I'm using litespeed myself, and upped max php processes from 10 to 30. This drove the time way, way down. However, the down side to this is that I'm now seeing 20-30 lsphp processes every time a WHMCS bridge page is loaded. I know it's that specific page, because, well, site's not open yet and I haven't sent any traffic but my own there.

Just thought I'd offer my own 0.02. Seems that they've got an unusual number of php processes spawning here.

Ilyas 07-05-2016 05:54 AM

I had a similar issue two years ago... I never got it resolved but it was something with my cache. Eventually, I ditched the plugin and went for a custom intigration. It took a long time but it was definitely worth it.


All times are GMT -6. The time now is 04:00 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.1.0